Results 1 to 6 of 6

Thread: ASUS A7N8X-E Deluxe and SATA Hard Drives...

  1. #1
    Join Date
    Jul 2009
    Posts
    7
    Rep Power
    0

    ASUS A7N8X-E Deluxe and SATA Hard Drives...

    Hi Friends,

    My PC Config
    ------------
    CPU Type = AMD Athlon XP, 1913 MHz (11.5 x 166) 2600+

    MotherBoard = ASUS A7N8X-E Deluxe REV 2.xx
    Motherboard Chipset = nVIDIA nForce2 Ultra 400
    nVidia nForce2 MCP-T

    Main BIOS = Phoenix-Award BIOS v6.00PG
    ASUS A7N8X-E Deluxe ACPI BIOS Rev 1013

    Silicon Image SATA Link Sil3112ACT144 (Chipset)
    Sil3112A Sata Raid BIOS version 4.2.47 (Current version)


    System Memory = 1024 MB (DDR SDRAM)
    Monitor = HP w1907 19" TFT LCD Widescreen
    Hard Disk Drive = ST332062 0SV SCSI Disk Device (320 GB, 7200 RPM, SATA-II)
    Graphics Card = Gigabyte GV-R96X128D (ATI Radeon 9600XT) (128 MB DDR)
    Optical Drive = BENQ DVD DD DW1640 (DVD Writer) (IDE)
    Optical Drive = LITE-ON DVDRW LH-20A1S SCSI CdRom Device (DVD Writer) (SATA)
    Graphics Card -- Gigabyte GV-R96X128D (ATI Radeon 9600XT) (128 MB DDR)
    SMPS -- AC 230V ATX-Switching Power Supply Model: LC-B500E (Total Output: 500W)
    UPS -- APC Back-UPS ES 500 (500VA) (230 V) (300 Watts)
    Microsft USB Mouse
    Logitech Keyboard(PS/2)
    AltecLansing AVS 300 2.1 Speakers System
    Zebronics ATX Cabinet Model: ZEB-211A-Elegance


    OS -- Windows XP Professional with SP3 (Modded XP)

    Note: Windows XP Sp3 never detected my 320 GB sata hard drive. I have to use a modded XP (Sil3112A drivers slipstreamed) / use F6 and floopy procedure to install sata drivers...


    There are 2 SATA ports in mobo. SATA Raid 1 and SATA Raid 2. I don't know which one is Primary sata port and Secondary/slave port. I see SATA RAID jumpers are enabled in my mobo. I have connected my Seagate SATA-II 320 GB hard drive to "SATA Raid 1" port and Sata optical drive to "SATA Raid 2".

    My Seagate SATA-II 320 GB hard drive is never listed / not seen in the BIOS, but I can see both the 320 GB sata hard drive and Sata optical drive while the PC is booting up.

    So, a few days back I flashed my BIOS following the guide by "iissmart" reply in post #13 of the below link
    https://technutopia.com/forum/showthread.php?t=6461

    Even after flashing the BIOS to the latest update my sata hard drive is not listed / seen in the BIOS. In BIOS I could not even find a single Option that says "SATA" and can't even find a world SATA in my BIOS even after updating the BIOS.

    I see only this in my BIOS "Advanced BIOS features --> RAID or SCSI Card Boot" and no SATA option, so I think theres no way my Sata hard drive will be listed in the BIOS. I can only see the sata devices while booting the PC.


    Very soon I will be a new 1 TB WD Caviar Green WD10EADS to my mobo. I'm planning to remove/replace the Sata optical Drive and connect the new 1 TB WD Sata Hard Drive to "SATA Raid 2" port. My plan is to keep the current Seagete 320 sata as Primary Master and add the new 1 TB Sata hard drive as Secondary / Salve.

    I don't want to configure my 2 sata hard drives as Raid. I want it to recognized just as two individual SATA Hard Drives configured as Primary Master(320 GB) and Slave (1 TB).

    Questions...

    1. Will my mobo. detect the new 1 TB hard drive while booting up ?

    2. Is there any option in my mobo. to set which sata hard drive to configure it as Master and Secondary / slave ? ( I don't see any option in mobo. to set the hard drive as master / slave). Is there any jumper settings.

    3. In case of having 2 sata hard drives, Will there be any issues in identifying which hard drive is master and slave. I guess the 320 hard drive having the OS will be considered as primary master by default, and the other 1 TB will be automatically taken as slave.

    4. After adding the new 1 TB Hard Drive will my mobo. / BIOS / Win. XP SP3 will be able to identify it properly without any problems. I guess it may be a problem for Old motherboard to identify these large 1 TB hard Drives and thats when it hangs at the SATA RAID area of booting up as I read it from other topics in this forum ? Will I encounter the hanging problem ?

    4. For example by adding a SATA PCI card to my mobo. and plugging the 320 GB and 1 TB hard drives to the PCI card. Is it necessary / my mobo. sata raid ports are more than enough to identify the 2 hard drives without any problems.


    Thanks and Regards
    Rafales

  2. #2
    Join Date
    Jul 2005
    Location
    The land of 100Mbps
    Age
    25
    Posts
    2,033
    Rep Power
    10
    1. If your current configuration isn't detecting the 320GB drive or the SATA optical drive, it probably won't detect the 1TB drive either. You need to get the other drives working first. What do you mean when you say "but I can see both the 320 GB sata hard drive and Sata optical drive while the PC is booting up"?

    2. The concept of "Master/Slave" is only relevant to IDE devices, not SATA, so there is no need to worry about what they are set to. Some BIOS's will configure SATA devices as IDE devices (for legacy reasons), so this is why you may see your SATA devices listed along with IDE devices as a Master/Slave.

    3. See #2

    4. If XP can't see the 320GB drive it won't see the 1TB drive. The BIOS needs to see the SATA drives first in order for XP to see them as well.

    The other #4. If you can't get the devices to be recognized using the onboard SATA controller, it may help to find a SATA PCI card and use that. Keep in mind you may also have to flash the PCI card's BIOS to a newer version if you buy an older model card.

    I hope that helps! Sorry for the late reply...

  3. #3
    Join Date
    Nov 2009
    Posts
    7
    Rep Power
    0

    Frustrated

    I originally posted this on the thread mentioned in Rafales post #1 however that thread is considered resolved when my issue has not been addressed.

    First, thanks to iissmart for the clear directions - this sorta worked but not entirely. My plan is to add two 1TB Seagate SATA drives in a mirrored configuration for data security. All the usual issues as described in this thread occurred.

    First I have two A7N8X mobos, one is a A7N8X-E Deluxe Rev 1.01 and the other is an A7N8X Deluxe pcb 1.04. Updated both mobos with their respective Bios' (c18e1013 and AN8D1008) after using cbrom215 and the SATARAID Bios 4284 per iissmart's instructions. Also updated the Silicon Image ATA Driver to the latest version of V1.0.62.0. After updating all the bios' and drivers both mobos recognise the drives and their capacities and confirm that 4.2.84 SATARAID Bios is loaded. I have two challenges remaining:


    1. A7N8X-E Deluxe. This mobo works fine with the two 1TB drives providing they are not in a mirrored configuration. I mirrored the drives (doesn't that take a long time for 1TB) and the SATA boot screen recogises the SIL Mirrored Set but after the PCI Deveice Listing and Verifying DMI Pool Data screens, I get the following error "A disk read error occured. Press Ctrl+Alt+Del to restart". I have tried all combinations of boot sequences in the bios but no joy. If I delete the raid set and just have two independent HDDs Windows XP Pro boots fine and through Windows Explorer both drives are working (and are exact copies). Just cannot boot with a mirrored set.
    2. A7N8X Deluxe. This mobo recognises the the two drives is the SATA Bios screen; however, before the usual Windows Welcome screen comes, the black screen of death arrives as per REIGER in post #33. This occurs for both 500Gb and 1TB HDD irrespective of RAID configuration and also when trying only one drive connected.

    So, for all your people out there that are way smarter than me on these issues I seek your recommendations.

    Also the following could be of interest from the Asus website:
    The ASUS Tech support webpage provides the following:

    • As the A7N8X series mobos are considered legacy mobos by ASUS there will be no more BIOS updates. So for the A7N8X-E Deluxe model the final BIOS will be v1013 while for the A7N8X Deluxe model the final version is 1008 (or 1009 in beta version).
    • They also state that the SATA chips on the mobos can only handle SATA HDD capacity less than 2TB. It does not state the maximum capacity HDD that can be handled.
    • No support info for mirrored RAID sets as per my issue

  4. #4
    Join Date
    Nov 2009
    Posts
    7
    Rep Power
    0

    To Rafales

    Rafales,

    Not rying to tell you to suck eggs but confirm you have updated the Silicon Bios to 4.2.84 as per IISSMART's directions and the Serial SATA jumper setting covers the pins 1 and 2 of the three pin jumper selection. Also, confirm that when booting you get tothe Silicon Bios screen (where you can view what Silicon bios is loading, e.g. 4.2.84) and yor drives are listed. Should look something like but with 4.2.84 rather than 4.2.47:

    Sil 3112A SATARaid BIOS Version 4.2.47
    Copyright (C) 1997-2004 Silicon Image, Inc.

    Press <Ctrl+S> or F4 to enter RAID utility
    0 ST380013AS 76293 MB

    In the example above ST380013AS would be connected to SATA RAID 1 port (even though it starts with 0).


    You will not see any mention of SATA in the A7N8X-E deluxe 1013 bios. The boot settings I have always used are RAID, HDD0, CDROM, FLOPPY; however I use a RAID mirrored set. I suggest you try these settings first and then try SCSI, SCSI, HDD0, CDROM.

    Regarding your question 3 about MASTER and SLAVE, the A7N8X will boot first from SATA RAID 1 port then SATA RAID 2 providing the HDD connected to RAID 1 has an OS installed. So, connect the HDD you wish to boot from on SATA RAID 1.

    Assuming the computer boots to Windows OK, check Windows Explorer and see if all the drives are connectd and working.

    Hope this helps.

  5. #5
    Join Date
    Jul 2009
    Posts
    7
    Rep Power
    0
    Sorry for the very delayed reply iissmart. Your guide on how to mod the BIOS was very useful and it helped me to solve the issue.

    And Thanks to Ullal and as per his post I updated the BIOS version to 4.2.50 and it worked well for me

    And thanks to chookduck for the detailed replies.

    My new 1 TB hard drive was successfully recognized and working fine now
    Thanks to iissmart and Ullal for the guide and help.

    Has anyone tried Windows 7 in ASUS A7N8X-E Deluxe, does it recognize all the hardware....

  6. #6
    Join Date
    Nov 2009
    Posts
    7
    Rep Power
    0
    Update to my post #3 above. FOr some unexplained reason, the A7N8X Deluxe now works. Just turned it on the other day and for some reason, all good mind you, the mobo recognised the SATA HDDs and booted fine. Mirrored two 500 Gb Seagate drives and all is OK.

    Still have the same issue about the A7N8X-E deluxe and not being able to mirror and boot.

Similar Threads

  1. Replies: 118
    Last Post: 04-09-2014, 01:07 AM
  2. Asus a7n8x Deluxe Motherboard and WD green 2TB SATA drive
    By sabih786 in forum Hardware Support
    Replies: 2
    Last Post: 12-12-2009, 07:44 PM
  3. [Resolved] Asus A7N8X-E Deluxe, Kingston Traveller 1GB USB Flash Drive Boot Error
    By liquidmonkey in forum Hardware Support
    Replies: 8
    Last Post: 03-21-2009, 06:26 PM
  4. {Hard Drives} Saving Data from Crashed Hard Drives
    By mexicanman97 in forum Hardware Support
    Replies: 24
    Last Post: 02-13-2009, 09:03 AM
  5. Replies: 3
    Last Post: 07-25-2007, 03:51 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •